avataxforstripe.com throwing 400 error during stripe webhook call

  • 1
  • Question
  • Updated 3 months ago
I was using the following guide to connect avalara with our stripe account.
https://help.avalara.com/FYHP/AvaTax_Update_for_Stripe_Invoicing/Install_and_Configure_Avalara_AvaTax_for_Stripe_Invoicing

based on this guide I have assumed that https://avataxforstripe.com is also service provided by avalara which makes integrating with stripe easy.
As explained in the guide https://avataxforstripe.com
uses stripe webhooks to capture transaction from user and apply tax
based on customer’s address. When I completed integration following all steps in guide, I saw that most of the webhooks sent by stripe to https://avataxforstripe.com are failing and because of that I am not able to test our integration with avalara.
Photo of Hardik Patel

Hardik Patel

  • 1 Post
  • 0 Reply Likes

Posted 3 months ago

  • 1
Photo of Charlie Morrisette

Charlie Morrisette, Product Manager, Internal Connector Development

  • 209 Posts
  • 14 Reply Likes
Hi Hadrik,

A 400 error could mean that your token has expired and we are unable to retrieve a valid token.  One potential solution is to sign out from avataxforstripe.com web service and attempt to sign back in.  Should that not work, I would recommend contacting our Support team as there may be some account specific information we would need to troubleshoot.

Once you have opened a case with please respond back to this thread with that ticket number and we'll help get that to the right people to help.

Thank you,

Charlie