ruby: companyCode: 'DEFAULT',

  • 1
  • Question
  • Updated 2 years ago
hi,
i am using the ruby gem. i have one default compnay in the account set to test.

here the result from the script:
{"error"=>{"code"=>"GetTaxError", "message"=>"Company not found.  Verify the CompanyCode.", "target"=>"Unknown", "details"=>[{"code"=>"GetTaxError", "number"=>300, "message"=>"Company not found.  Verify the CompanyCode.", "description"=>"DEFAULT", "faultCode"=>"GetTaxError", "helpLink"=>"http://developer.avalara.com/avatax/errors/GetTaxError";, "refersTo"=>"CompanyCode", "severity"=>"Error"}]}}


if i leave the company code out, then i get this:
{"error"=>{"code"=>"GetTaxError", "message"=>"No Operations are allowed for an inactive company.", "target"=>"Unknown", "details"=>[{"code"=>"GetTaxError", "number"=>300, "message"=>"No Operations are allowed for an inactive company.", "description"=>"TOMABROAD", "faultCode"=>"GetTaxError", "helpLink"=>"http://developer.avalara.com/avatax/errors/GetTaxError";, "refersTo"=>"CompanyCode", "severity"=>"Error"}]}}


any ideas? thx
Photo of tomabroad

tomabroad

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Robert Bronson

Robert Bronson

  • 5 Posts
  • 0 Reply Likes

Hello, sorry you are having trouble.  Without specific examples of your script I can only suggest things to try.  I don't know if you are using the "production" or "sandbox" environment, but remember that they are completely separate.  In order to make calls to the sandbox environment you need to have a company set up there specifically, because it cannot "see" any of the companies you have in your production account.

For more information on Sandbox and Production envrironments you can take a look at our Developer Guide.

If you are able to send us a sample of the code you are trying to execute, we would be glad to help you look into this further.

Best,

Robert Bronson